Author Topic: v1.11 - Bug fix goodness!  (Read 4007 times)

0 Members and 1 Guest are viewing this topic.

Offline Megiddo

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 6215
  • Karma: 394
  • Project Lead
v1.11 - Bug fix goodness!
« on: February 20, 2006, 12:13:13 PM »
Thanks goes to andrejkw for pointing out a flaw in the new configuration system's design ( see this thread for more information ).

ULX v1.11 fixes this bug, please update!

EDIT: By the way, for those who may be interested, I made a small module for ULX called sendmenu. You can read about it here.
« Last Edit: February 22, 2006, 08:27:10 PM by Megiddo »
Experiencing God's grace one day at a time.

Offline scorpion

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
Re: v1.11 - Bug fix goodness!
« Reply #1 on: February 20, 2006, 02:37:14 PM »
I dont know if its just me, but this update completely disabled the chat pickups. like @@@ or !votekick... But it did get the weapons menu to work.. cool. I had the same mingekick problem.. but for now im willing to have a broken mingekick and have my chat pickups works. See if you can replicate this issue.

Offline Megiddo

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 6215
  • Karma: 394
  • Project Lead
Re: v1.11 - Bug fix goodness!
« Reply #2 on: February 20, 2006, 03:19:02 PM »
You have to put a space between the '@@@' and what you want to say. I just tested it, works fine.
Experiencing God's grace one day at a time.

Offline scorpion

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
Re: v1.11 - Bug fix goodness!
« Reply #3 on: February 21, 2006, 03:46:02 AM »
Yes i know that. i have been using ulx for a substancial amount of time. So far i have a feeling that this may be related to execution of the script that starts support for the copy gun on the server. It then stops the chatpickups in the same way that when the RP script is run, the chat pickups also do not work then. (chat pickup = stuff you type in chat that ulx recoginzes as a cmd, in case i sound dumb up there)

In version 1.11 the weapons menu seems to now fully work. causing the copygun script to be loaded. Normaly i execute the copygun script via console by lua_openscript when i want to use it since i have excluded it in the swep_menu.lua file. When i do this the chat command stop working. I think its the execition of that, has an effect on the chat commands in the game. The same is true if the RP script is loaded via lua_openscript. Just now in 1.11 the copygun is autoloaded so it causes the commands to be disabled on startup.
« Last Edit: February 21, 2006, 03:52:34 AM by scorpion »

Offline jesus

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 0
Re: v1.11 - Bug fix goodness!
« Reply #4 on: February 25, 2006, 04:12:31 PM »
Just thought I'd add that when you install mani "@@@" commands don't work because mani uses them.
I changed the ulx_util to use ### but it doesn't work.
Also:
/p is killed, but mani doesn't use that.
Prop protection is still dodgy.
You should make it if I do a command on myself it should allow it no matter if i'm immunised or not, and it should be allowed to be turned on and off in configs.
Adverts should use mani's system of time inbetween adverts rather than time until, to stop overlapping ads.
I can't change my own team to spectator, someone has to do it for me.

I'll think of more, because there are more. Lots.