Author Topic: ulx noclip always activated  (Read 545 times)

0 Members and 1 Guest are viewing this topic.

Offline Androthus

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
ulx noclip always activated
« on: April 21, 2018, 02:22:53 PM »
Hello i have this problem since the begining, i have "sbox_noclip 0" in server.cfg, disabled global noclip in server settings, but because of the enabled noclip in ulx settings / sandbox, every player can noclip, every server restart it keep the noclip enabled, how can i get rid of it please ?


Offline JamminR

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 7906
  • Karma: 372
  • Sertafide Ulysses Jenius
    • Team Ulysses [ULib/ULX, other fine releases]
Re: ulx noclip always activated
« Reply #1 on: April 21, 2018, 02:38:24 PM »
The command isn't sbox_noclip.
Try "sv_noclip 0" in your config file.

ULX has no saved configuration and will only show current status in the panel you reference.
« Last Edit: April 21, 2018, 02:40:38 PM by JamminR »
The price one pays for pursuing any profession or calling is an intimate knowledge of its ugly side. - James Baldwin

Offline Androthus

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: ulx noclip always activated
« Reply #2 on: April 21, 2018, 02:57:32 PM »
i host a private server atm but i assum the configuration is the same as a real server, i have put "sv_noclip 0" in server.cfg but when i run the server it says "Unknown command "sv_noclip"" what should i do ? ( and the noclip is also enabled again )


Offline JamminR

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 7906
  • Karma: 372
  • Sertafide Ulysses Jenius
    • Team Ulysses [ULib/ULX, other fine releases]
Re: ulx noclip always activated
« Reply #3 on: April 21, 2018, 08:44:25 PM »
Ok, now that I search google, perhaps it is sbox_noclip. Sorry.

Either way, ULX will not change it during a restart.
ULX only shows what it is when you load that menu, as the note indicates.

You likely have some other addon or config changing it after autoexec runs.
Make sure sbox_noclip isn't in the config twice.
The price one pays for pursuing any profession or calling is an intimate knowledge of its ugly side. - James Baldwin

Offline Androthus

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: ulx noclip always activated
« Reply #4 on: April 22, 2018, 03:10:25 AM »
i have found a error, when i put "sbox_noclip" myself in the server console command it say this


Offline MrPresident

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 2642
  • Karma: 413
    • |G4P| Gman4President
Re: ulx noclip always activated
« Reply #5 on: April 22, 2018, 10:50:46 AM »
That just means that it is currently enabled on your server. You'll need to figure out why it keeps enabling.

As JamminR has said, the ULX menu only shows the current setting and allows for you to easily change it in game. We don't build or save configurations when you enable/disable things in the menu. Just because the ULX menu is telling you that it's enabled, doesn't mean that ULX is enabling it. Does that make sense?

If you have something like Notepad++ you can do a find in files for your gmod directory for "sbox_noclip" and see where else it might be getting set. You probably have a double config somewhere that is overwriting it.

Offline Androthus

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: ulx noclip always activated
« Reply #6 on: April 22, 2018, 02:20:23 PM »
i have found the problem, it was my ulx-master and ulib-master files who created this bug idk why because i have downloaded theses files in the GitHub of TeamUlysses, i replaced them and know it works, thank you for the ( pretty fast ) help guys ^^

Edit : ulx was not the responsable, i created a new private server and one of these fils was the culpit, when I copied theses files from the new server on my main server everything went as before with the noclip unchecked in the ulx setting of the !menu



idk why
« Last Edit: April 22, 2018, 03:08:01 PM by Androthus »