Author Topic: error spammed in console  (Read 245 times)

0 Members and 1 Guest are viewing this topic.

Offline chauklet

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
error spammed in console
« on: February 12, 2019, 03:55:23 PM »

My ULib/ULX versions (run "ulx version" in console):
ULib v2.63
ULX v3.73

Game mode(s) I am having this problem on:DarkRP

Lua errors shown in console, if any:
Code: [Select]
[ERROR] loadServerEnd:3: attempt to call method 'SendLua' (a nil value)
  1. fn - loadServerEnd:3
   2. unknown - addons/ulib/lua/ulib/shared/hook.lua:109

just recently I made a darkrp server and installed a few addons but now whenever I join the server my console in game is spammed with the error as well as my server console


Offline Megiddo

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 6204
  • Karma: 394
  • Project Lead
Re: error spammed in console
« Reply #1 on: February 12, 2019, 06:44:09 PM »
Find which addon is defining loadServerEnd. Even though ULib shows in the trace, the error is not coming from ULib.
Experiencing God's grace one day at a time.

Offline JamminR

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 7971
  • Karma: 373
  • Sertafide Ulysses Jenius
    • Team Ulysses [ULib/ULX, other fine releases]
Re: error spammed in console
« Reply #2 on: February 12, 2019, 06:50:54 PM »
It's not ULib causing it. (The only reason you even see ULib far down the trace is because we enhance the hook system)
It's not ULX causing it.

You have an addon causing that.
And from what little I can find searching for gmod and "loadserverend", it might be a back door of some sort.
Exploit/Backdoor References
https://pastebin.com/TJ8SwhzB
https://pastebin.com/cUYnXZjw
https://nulledbb.com/search.php?action=results&sid=213b9cbcc2208fe188bf5be68491769c&sortby=&order=desc


The price one pays for pursuing any profession or calling is an intimate knowledge of its ugly side. - James Baldwin