Author Topic: Error stopping ULX from running  (Read 560 times)

0 Members and 1 Guest are viewing this topic.

Offline YWnightmare

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Error stopping ULX from running
« on: May 02, 2019, 08:19:00 AM »
My ULib/ULX versions: <SVN> revision 356
ULib v..
ULX v..

Game mode(s) I am having this problem on: DarkRP

Lua errors shown in console, if any:
Code: [Select]
[ERROR] addons/ulx-master/lua/ulx/end.lua:49: attempt to index a string value with bad key ('red' is not part of the string library)

  1. error - [C]:-1

   2. __index - lua/includes/extensions/string.lua:297

    3. fn - addons/ulx-master/lua/ulx/end.lua:49

     4. fn - addons/ulx-master/lua/ulx/end.lua:131

      5. unknown - addons/ulib-master/lua/ulib/shared/hook.lua:109
Hello,
Every time I run my server I get this error. I have tried re-installing both ULX and ULIB, but I still get this error. I have also disabled any new addons and still have this error. This causes xgui to not work and ULX to break, for example groups do not work, noclip doesn't work, etc. Do you know what is causing this error? I have not modified anything from the ULX files and have not changed any base game files.

Offline JamminR

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 8027
  • Karma: 381
  • Sertafide Ulysses Jenius
    • Team Ulysses [ULib/ULX, other fine releases]
Re: Error stopping ULX from running
« Reply #1 on: May 02, 2019, 07:23:31 PM »
That error is not common, nor something directly inherit in our code.
Did you attempt to edit adverts?
That loop is what edits the advert colors.
« Last Edit: May 02, 2019, 07:25:35 PM by JamminR »
"Though a program be but three lines long, someday it will have to be maintained." -- The Tao of Programming

Offline YWnightmare

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: Error stopping ULX from running
« Reply #2 on: May 06, 2019, 02:42:14 PM »
Sorry for the late reply.
I have not edited anything from ulx yet, all I have done is add ranks and edit the MOTD. Is it possible another addon is causing conflict? I even deleted and re installed the ULX and ULIB folders but still get the error.

Offline Timmy

  • Ulysses Team Member
  • Full Member
  • *****
  • Posts: 218
  • Karma: 161
  • Code monkey
    • ULX Unofficial Documentation
Re: Error stopping ULX from running
« Reply #3 on: May 08, 2019, 10:53:14 PM »
Yes, that error is caused by an improperly formatted adverts.txt file.

It's hard to say exactly who or what caused this without some more information.

To better understand this problem, can you attach <garrysmod>/data/ulx/adverts.txt to your next post?

You can attach a file directly to your post. When you Reply, click the "Attachments and other options" link to open an upload form.
“When given the choice between being right or being kind, choose kind.”  —Dr. Wayne Dyer

Offline YWnightmare

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: Error stopping ULX from running
« Reply #4 on: May 10, 2019, 10:29:40 AM »
This is my adverts.txt from garrysmod/data/ulx/data . Just a plain file, nothing in there.

Offline Timmy

  • Ulysses Team Member
  • Full Member
  • *****
  • Posts: 218
  • Karma: 161
  • Code monkey
    • ULX Unofficial Documentation
Re: Error stopping ULX from running
« Reply #5 on: May 10, 2019, 10:41:35 AM »
The very first line of that file is:

Code: [Select]
--#NoSimplerr#
That's what is causing the error.

Lua comments (--) do not work in this file. The adverts.txt file uses a semicolon (;) for comments instead.

Delete or comment that first line, then restart your server. That should fix the error.
« Last Edit: May 10, 2019, 12:08:37 PM by Timmy »
“When given the choice between being right or being kind, choose kind.”  —Dr. Wayne Dyer