Author Topic: ulx issues  (Read 2084 times)

0 Members and 1 Guest are viewing this topic.

Offline zlac

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
ulx issues
« on: May 22, 2019, 11:44:55 AM »
I am having issues after I have reinstalled my server 3 times now, with users having the ability to use noclip even when on noacess. Please help. I have tried to disable global noclip inside of the server.config, "sbox_noclip          0" and that just disabled the entire noclip on the server.

My ULib/ULX versions (run "ulx version" in console):
ULib v2_63
ULX v3_73

Game mode(s) I am having this problem on: DarkRP

Lua errors shown in console, if any:
« Last Edit: May 22, 2019, 12:06:40 PM by zlac »

Offline JamminR

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 8083
  • Karma: 389
  • Sertafide Ulysses Jenius
    • Team Ulysses [ULib/ULX, other fine releases]
Re: ulx issues
« Reply #1 on: May 22, 2019, 08:04:11 PM »
Though it's been many years since I ran a gmod server, I'm pretty sure;
1) the file is "server.cfg", not "server.config", though, there are command line options to use different config files at startup.
2) it's "sv_noclip 0", not "sbox_noclip 0"
3) Even if I'm wrong about #2, that's what setting 0 on the server does, disables for all but those with ULX access to noclip.
4) DarkRP very likely has it's own controls for noclip - we don't know though.
5) Moving this thread, as it's more a general Gmod/DarkRP than it is for ULX (we can move back if it comes back to discussion regarding much ULX help)
« Last Edit: May 22, 2019, 08:05:42 PM by JamminR »
"Though a program be but three lines long, someday it will have to be maintained." -- The Tao of Programming