Author Topic: ULX Echoing Twice and !menu not working.  (Read 2415 times)

0 Members and 1 Guest are viewing this topic.

Offline ?oyal

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
ULX Echoing Twice and !menu not working.
« on: December 29, 2021, 02:30:19 AM »
My ULib/ULX versions: ULib v2.63 | ULX v3.73
Gamemode: DarkRP Base but SWRP
I get this lua error but I'm not sure if its related:
Code: [Select]
[ULib] HTTP failed - ISteamHTTP isn't available!
1. Fetch - lua/includes/modules/http.lua:42
2. unknown - lua/ulib/shared/plugin.lua:186
3. dlib_has_nothing_to_do_with_this_traceback - [C]:-1
4. CallStatic - lua/dlib/modules/hook.lua:1106
5. unknown - lua/dlib/modules/hook.lua:1189
This problem started recently and I have no clue as to the cause or the fix. Basically ULX just echos the command twice and !menu just disappears when you try opening it. (ulx menu in console still works)


I have uninstalled ULX and reinstalled it but that did nothing. (Deleted data/ulib + data/ulx and the addons) The problem still persists, anything would help at this point.
Only chat commands echo twice, normal menu commands don't echo twice.
« Last Edit: December 29, 2021, 11:19:08 PM by ?oyal »

Offline ?oyal

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: ULX Echoing Twice and !menu not working.
« Reply #1 on: December 29, 2021, 11:20:09 PM »
Fixed it, apparently, a hologram tool broke it. After uninstalling the hologram tool ULX worked flawlessly.