Author Topic: Having issues with temp bans on my server.  (Read 1450 times)

0 Members and 1 Guest are viewing this topic.

Offline Dionysus9517

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Having issues with temp bans on my server.
« on: September 10, 2022, 05:30:04 PM »
My ULib/ULX versions (run "ulx version" in console):
ULib v2.71d (08/05/22)
ULX v3.81d (08/05/22)

Game mode(s) I am having this problem on:
Star Wars RP (darkrp modification)

Hi, I've recently begun setting up my gmod SWRP server and have run into an issue with ulx banning. During development, some of my friends have been helping me and joining the server to mess around and have a bit of fun while i'm sorting stuff out. These antics lead to fake joke bans, but we ran into an issue when someone tried a temp ban of 3 years.

He got banned for 3 years, i saw the message in chat, and then then i saw another message saying [user] unbanned [steamid]. I got on the next day and he asked me to unban him, which is when we realised that we had an issue with temp bans. After testing stuff out on another user using 1 minute bans, we found that

A. We could not revoke temp bans (even though it said in chat that the user was unbanned)
B. No bans were being recorded in the ban section of the ulx menu

We have not tried this with permanent bans (because i'm obviously worried that another person is unabled to be unbanned). However, i myself had been joke banning people a couple days before and we only ran into this issue when we tried a ban that had a timer.

I'm terribly sorry if the answer is more obvious than i suspect or if this post is silly, I have looked through and tried solutions from these forums, reddit threads and steam posts but to no avail.