Author Topic: Sourcebans & ULX/ULib  (Read 65426 times)

0 Members and 1 Guest are viewing this topic.

Offline Sidewaykill

  • Newbie
  • *
  • Posts: 8
  • Karma: 2
Re: Sourcebans & ULX/ULib
« Reply #30 on: December 20, 2012, 06:26:14 PM »
Ok. Does it say something like this?

ServerLog: [12/21/12 13:14:19][SourceBans.lua] Loading Admin Groups . . .
[12/21/12 13:14:19][SourceBans.lua] Loading Admin Groups . . .

If it doesn't, it is not actually connecting to the database. When a player joins, does it say something like "error connecting to the database at 192.168.2.1 db name db user USING PASSWORD: YES"?
If so, you must enable remote mySQL on your server from your game server IP/s, or make sure your database user information is correct. Trust me, I had many difficulties getting SourceBans working.

Offline talmera

  • Newbie
  • *
  • Posts: 36
  • Karma: 4
    • Tectonic-Gaming
Re: Sourcebans & ULX/ULib
« Reply #31 on: December 21, 2012, 07:06:48 AM »
1st time I tried using this was before you rewrote the original post and I failed miserably, after that it was much easier to understand and it works perfectly on both my servers using the advanced method! big thumbs up for making this <3
It's not a sin if it can't make me cry
He's not the devil unless there's fire in his eyes
It ain't the ghost if it don't speak in tongue
It's not a victory 'till the battles been won

Offline goodman854

  • Newbie
  • *
  • Posts: 14
  • Karma: 2
Re: Sourcebans & ULX/ULib
« Reply #32 on: December 23, 2012, 02:58:36 PM »
not working for me I'm getting the following issue. And I'm fairly certain everything is correctly in place.
Quote
[ULIB] Loading SHARED module: ulx_init.lua
///////////////////////////////
//       ULX Admin Mod       //
///////////////////////////////
// Loading...                //
//  sh_defines.lua           //
//  lib.lua                  //
//  base.lua                 //
//  sh_base.lua              //
//  log.lua                  //
//  MODULE: slots.lua        //
//  MODULE: sourcebans_init.lua//
Couldn't include file 'includes\modules\mysqloo.lua' (File not found) (@addons/ulx/lua/includes/modules/sourcebans.lua (line 24))

[ERROR] addons/ulx/lua/includes/modules/sourcebans.lua:24: Module not found!
  1. require - [C]:-1
   2. unknown - addons/ulx/lua/includes/modules/sourcebans.lua:24
    3. require - [C]:-1
     4. unknown - addons/ulx/lua/ulx/modules/sourcebans_init.lua:5
      5. include - [C]:-1
       6. unknown - addons/ulx/lua/ulx/init.lua:28
        7. include - [C]:-1
         8. unknown - addons/ulx/lua/ulib/modules/ulx_init.lua:2
          9. include - [C]:-1
           10. unknown - addons/ulib/lua/ulib/init.lua:75
            11. include - [C]:-1
             12. unknown - addons/ulib/lua/autorun/ulib_init.lua:3


[ERROR] addons/ulx/lua/ulx/modules/sourcebans_init.lua:5: Module not found!
  1. require - [C]:-1
   2. unknown - addons/ulx/lua/ulx/modules/sourcebans_init.lua:5
    3. include - [C]:-1
     4. unknown - addons/ulx/lua/ulx/init.lua:28
      5. include - [C]:-1
       6. unknown - addons/ulx/lua/ulib/modules/ulx_init.lua:2
        7. include - [C]:-1
         8. unknown - addons/ulib/lua/ulib/init.lua:75
          9. include - [C]:-1
           10. unknown - addons/ulib/lua/autorun/ulib_init.lua:3

//  MODULE: uteam.lua        //
//  MODULE: votemap.lua      //
//  MODULE: xgui_server.lua  //
///////////////////////////////
// ULX GUI -- by Stickly Man //
///////////////////////////////
// Adding Main Modules..     //
//  bans.lua                 //
//  commands.lua             //
//  groups.lua               //
//  maps.lua                 //
//  settings.lua             //
// Adding Setting Modules..  //
//  client.lua               //
//  server.lua               //
// Adding Gamemode Modules.. //
//  sandbox.lua              //
// Loading Server Modules..  //
//  sv_bans.lua              //
//  sv_groups.lua            //
//  sv_maps.lua              //
//  sv_sandbox.lua           //
//  sv_settings.lua          //
// XGUI modules added!       //
///////////////////////////////
//  MODULE: chat.lua         //
//  MODULE: fun.lua          //
//  MODULE: menus.lua        //
//  MODULE: rcon.lua         //
//  MODULE: teleport.lua     //
//  MODULE: user.lua         //
//  MODULE: userhelp.lua     //
//  MODULE: util.lua         //
//  MODULE: vote.lua         //
//  end.lua                  //
// Load Complete!            //
///////////////////////////////

Offline JamminR

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 7840
  • Karma: 367
  • Sertafide Ulysses Jenius
    • Team Ulysses [ULib/ULX, other fine releases]
Re: Sourcebans & ULX/ULib
« Reply #33 on: December 23, 2012, 07:14:47 PM »
<clip>
Couldn't include file 'includes\modules\mysqloo.lua' (File not found)
<clip>
Seems pretty obvious, either you didn't install mysqloo lua file properly, or, one of the library files it requires wasn't installed properly. mysqloo itself requires two dll files placed in a specific location according to their linked directions.
The price one pays for pursuing any profession or calling is an intimate knowledge of its ugly side. - James Baldwin

Offline PAL-18

  • Full Member
  • ***
  • Posts: 142
  • Karma: 1
Re: Sourcebans & ULX/ULib
« Reply #34 on: December 25, 2012, 06:18:46 PM »
Ok. Does it say something like this?

ServerLog: [12/21/12 13:14:19][SourceBans.lua] Loading Admin Groups . . .
[12/21/12 13:14:19][SourceBans.lua] Loading Admin Groups . . .

If it doesn't, it is not actually connecting to the database. When a player joins, does it say something like "error connecting to the database at 192.168.2.1 db name db user USING PASSWORD: YES"?
If so, you must enable remote mySQL on your server from your game server IP/s, or make sure your database user information is correct. Trust me, I had many difficulties getting SourceBans working.

Yup, it says:

Code: [Select]
ServerLog: [Tue Dec 25 21:13:07 2012][SourceBans.lua] Starting the database.
Tue Dec 25 21:13:07 2012][SourceBans.lua] Starting the database.
ServerLog: [Tue Dec 25 21:13:08 2012][SourceBans.lua] Loading Admin Groups . . .
[Tue Dec 25 21:13:08 2012][SourceBans.lua] Loading Admin Groups . . .

But when a player joins, no database error messages display.

Offline centran

  • Newbie
  • *
  • Posts: 43
  • Karma: 8
Re: Sourcebans & ULX/ULib
« Reply #35 on: December 26, 2012, 07:56:25 AM »
Yes its loading, it says starting the database and im even able to use sm_ban.  But no bans are being read or written to the database.

So when you use the sm_ban command it shows on sourcebans or you just have access to the command but it doesn't do anything?

Offline PAL-18

  • Full Member
  • ***
  • Posts: 142
  • Karma: 1
Re: Sourcebans & ULX/ULib
« Reply #36 on: December 26, 2012, 03:45:34 PM »
I have access to command and and when i ban a user with it, they arent added to sourcebans.

Offline centran

  • Newbie
  • *
  • Posts: 43
  • Karma: 8
Re: Sourcebans & ULX/ULib
« Reply #37 on: December 27, 2012, 07:35:39 AM »
And there is no console errors? Hmmm? Not really sure what is going on if you go run sm_ban, use sm_ban but it doesn't show in sb.

Maybe you set the serverID to a server that doesn't exist. So then it never gets registered. Check you config file.

Offline Cyborg_delta1

  • Newbie
  • *
  • Posts: 8
  • Karma: 1
Re: Sourcebans & ULX/ULib
« Reply #38 on: December 29, 2012, 12:06:48 AM »
centran you are the best but I have one issue I have set every thing up and ULX is geting the admins and the usergroups from the source bans website, I have tested the banning via sm_ban and that works but when I use the ban button in the ULX GUI and give the ban time say 5min and the reason as minge it will ban the player and kick them but when I check the website it says the player has been banned permanently even though I have only asked for 5min any ideas on how to fix this?
« Last Edit: December 29, 2012, 01:39:07 PM by Cyborg_delta1 »

Offline centran

  • Newbie
  • *
  • Posts: 43
  • Karma: 8
Re: Sourcebans & ULX/ULib
« Reply #39 on: December 29, 2012, 04:18:44 PM »
centran you are the best but I have one issue I have set every thing up and ULX is geting the admins and the usergroups from the source bans website, I have tested the banning via sm_ban and that works but when I use the ban button in the ULX GUI and give the ban time say 5min and the reason as minge it will ban the player and kick them but when I check the website it says the player has been banned permanently even though I have only asked for 5min any ideas on how to fix this?

I couldn't reproduce. I was able to ban through the ban tab and it worked fine despite being really glitchy. I couldn't ban through the menu because it was glitched to badly. In both cases I noticed it defaults to a perma ban so that might have something to do with it.
The XGUI currently doesn't work completly so that might have something to do with it. Did you try banning through console using ulx ban or ulx banid. Or through chat using !ban?

Offline Cyborg_delta1

  • Newbie
  • *
  • Posts: 8
  • Karma: 1
Re: Sourcebans & ULX/ULib
« Reply #40 on: January 01, 2013, 03:07:18 PM »
I couldn't reproduce. I was able to ban through the ban tab and it worked fine despite being really glitchy. I couldn't ban through the menu because it was glitched to badly. In both cases I noticed it defaults to a perma ban so that might have something to do with it.
The XGUI currently doesn't work completly so that might have something to do with it. Did you try banning through console using ulx ban or ulx banid. Or through chat using !ban?

Yea !ban works fine but the XGUI always bans permanently what ever you put the length to but the reason works fine in the XGUI?

Offline centran

  • Newbie
  • *
  • Posts: 43
  • Karma: 8
Re: Sourcebans & ULX/ULib
« Reply #41 on: January 02, 2013, 09:13:27 AM »
Yea !ban works fine but the XGUI always bans permanently what ever you put the length to but the reason works fine in the XGUI?
Even though it was glitchy when tried to input the time, the time worked for me when I used the ban tab. However, xgui completely glitched out when I tried using the ban menu,
So, I am not sure if the problem is with the sourcebans code or if the xgui ban is setting the time as 0. I would recommend not using the xgui ban menu until it gets fixed as I think that it might be the problem. Especially since it seems to default to permanent.

Offline Stickly Man!

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 1258
  • Karma: 164
  • open(my $file, "<README") or die;
    • XGUI
Re: Sourcebans & ULX/ULib
« Reply #42 on: January 02, 2013, 09:38:05 AM »
Even though it was glitchy when tried to input the time,

.. I fixed that 16 days ago

Yea !ban works fine but the XGUI always bans permanently what ever you put the length to but the reason works fine in the XGUI?

I was able to successfully ban myself for 2 minutes using XGUI, no other addons installed besides ULX+ULib. Are you sure you're running the most up-to-date version?
"The stupidity of an individual on the Internet is generally matched only the by size of their ego, unless the individual in question is unaware of both." - Me

Offline Milk_

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: Sourcebans & ULX/ULib
« Reply #43 on: January 05, 2013, 01:02:50 AM »
I finally set all of sourcebans up, including the site.. but it isn't working properly.

If I ban somebody through the dashboard, it works perfectly but if I ban through the server (!ban) then the ban appears on the dashboard as expired instantly.. and the ban is still in place on the server.

edit: I'm not too sure if it's related.. but when I look at the ban, it said it was applied by Console and not the admin? Also, when the server is also starting up, I get "addons/ulx/lua/includes/modules/sourcebans.lua:247: attempt to index field 'Select Admin Groups' (a nil value)",  So I don't think I am class as an 'admin' in SB's eyes. When I attempt to use sm_csay hello, it says I do not have access to the command.



.. I fixed that 16 days ago

I was able to successfully ban myself for 2 minutes using XGUI, no other addons installed besides ULX+ULib. Are you sure you're running the most up-to-date version?

I also have the same problem with XGUI
« Last Edit: January 05, 2013, 01:23:26 AM by Milk_ »

Offline centran

  • Newbie
  • *
  • Posts: 43
  • Karma: 8
Re: Sourcebans & ULX/ULib
« Reply #44 on: January 07, 2013, 10:29:48 AM »
Also, when the server is also starting up, I get "addons/ulx/lua/includes/modules/sourcebans.lua:247: attempt to index field 'Select Admin Groups' (a nil value)",  So I don't think I am class as an 'admin' in SB's eyes. When I attempt to use sm_csay hello, it says I do not have access to the command.

Hmm.. Did you do the modification to line 137 of sourcebans.lua that allows all admins in sourcebans to be added?
It is can't find the query for Select Admin Groups and that is on lin 136. I am guess you messed something up.

If you want the module to load ALL admins in sourcebans and not just the ones you add to the server group in sourcebans then the lines 135-138 in sourcebans.lua should look like this
Code: [Select]
   -- Admins
    ["Select Admin Groups"] = "SELECT flags, immunity, name FROM %s_srvgroups";
--    ["Select Admins"] = "SELECT a.aid, a.user, a.authid, a.srv_group, a.srv_flags, a.immunity FROM %s_admins a, %s_admins_servers_groups g WHERE g.server_id = %i AND g.admin_id = a.aid";
    ["Select Admins"] = "SELECT a.aid, a.user, a.authid, a.srv_group, a.srv_flags, a.immunity FROM %s_admins a";