Author Topic: Garry's Mod Update and XGUI not working -- 3/9/2015  (Read 5836 times)

0 Members and 1 Guest are viewing this topic.

Offline Stickly Man!

  • Ulysses Team Member
  • Hero Member
  • *****
  • Posts: 1251
  • Karma: 162
  • open(my $file, "<README") or die;
    • View Profile
    • XGUI
Garry's Mod Update and XGUI not working -- 3/9/2015
« on: March 09, 2015, 11:14:55 AM »
A lot of people have been posting about issues with the recent Garry's Mod update and XGUI not opening. Everything is currently fixed and working fine on our development version of ULX, and we will be putting out a new release version as soon as we can.

If you need the fix immediately, please download the latest copy of ULX and ULib from our GitHub page, or via SVN.
"The stupidity of an individual on the Internet is generally matched only the by size of their ego, unless the individual in question is unaware of both." - Me

Offline Dannyy

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #1 on: March 09, 2015, 12:06:17 PM »
Still cannot use ULX?

Offline Dannyy

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #2 on: March 09, 2015, 12:11:29 PM »
Menu doesn't work; commands do though.

Offline YesBacon

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #3 on: March 09, 2015, 12:15:18 PM »
Read the post, download ulx and ulib from github and put them in. Works for me.

Offline sinistershades

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #4 on: March 09, 2015, 03:10:34 PM »
Yep. Works perfectly fine.

Thanks for the quick hotfix guys.

Offline CatsBananas

  • Newbie
  • *
  • Posts: 3
  • Karma: -1
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #5 on: March 09, 2015, 04:51:18 PM »
Do we just drop the Ulysses Master file in as a whole and delete the old versions of ULX and ULIB? And will I have to completely re-do my server ranks?

Offline Actowolfy

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #6 on: March 09, 2015, 06:12:10 PM »
Do we just drop the Ulysses Master file in as a whole and delete the old versions of ULX and ULIB? And will I have to completely re-do my server ranks?
Yes just paste the update and overwrite the old, as all ranks are located in your data folder so they won't be affected. The only thing you're replacing are the default files which are not used.

Offline allofmywutsteam

  • Full Member
  • ***
  • Posts: 133
  • Karma: 3
  • MNWO Owner
    • View Profile
    • Mo'nicas New World Order
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #7 on: March 09, 2015, 10:35:02 PM »
Just install the latest ulx/ulib updates to your addons/ folder and you're good to go.

groups and users are saved under data/ so they aren't affected.

Confirmed works.
"Then Jesus said to his disciples, 'Whoever wants to be my disciple must deny themselves and take up their cross and follow me.'" - Matthew 16:24



MNWO: Steam | Discord | Website | Forums | Join Server

Offline CatsBananas

  • Newbie
  • *
  • Posts: 3
  • Karma: -1
    • View Profile
Re: Garry's Mod Update and XGUI not working -- 3/9/2015
« Reply #8 on: March 09, 2015, 10:51:42 PM »
I used this version. But I ton of my commands showed up under a "_uncatagorized" category, and I couldn't actually use them in the menu. So I used the version of ULX/ULIB from my test server and it worked and brought back some of the commands.