Recent Posts

Pages: [1] 2 3 ... 10
Community Servers / KGN MethRP is back
« Last post by Mr. Knight on October 21, 2023, 02:27:37 PM »
Knight-Gaming-Networks Is bringing back Meth RP.
Tired of scrolling through a list of hundreds of servers look no more we are under our own Game-Mode.
Semi-Serious RP with drugs Weed and Meth "obviously" Realistic Police, Bitcoin Miners, ATM's, Slot Machine's and many more.
Help me bring back my childhood by making this game-mode great again...

PS.. if you see this and you join the server and you see the admin online and tell him "Meth RP Rocks" in chat and he sees it he will give you $100k ingame...
Hi there, thanks again for the provided help. Sorry if I have been taking long to answer, I've been busy these last days ^^

Fortunately and as you said, the said issue has been resolved, so I guess that it could still appear to be useful to people having such trouble in the future. The fix was to reset the entirety of the server, put back the addons and the data, and pouf, everything worked again.
I wasn't able to see anything amiss in the files you sent me. So hopefully the issues stay resolved for you! Let us know if you continue to have any issues, and feel free to swing by our Discord as you'll likely get some quicker response times there.
Community Servers / Odyssey CWRP Gaming
« Last post by Kenji on September 10, 2023, 06:29:49 PM »
Odyssey Gaming is a new CWRP server, and we'd love to expand our player base! We want to offer a fun experience to players,
 while also catering to their needs. We are dedicated to listening to our community and making the server an enjoyable experience.

We have dedicated Dev support, amazing hosting, good weapons, and more!

We would love to grow and expand, so come make suggestions! We'd love to hear from the community about what they want to see in the server.

This server is also really driven by roleplay and love to have tons of it on the server also!

Our Current Battalions are as follows:
501st Legion - Attack
Doom's Unit - Defense
104th Battalion - Mechanized
Shock Security - Military Police
Base Ops - Republic Command
After another day of struggle, I decided to clutch at straws and entirely wipe out the server in order to rebuild it from scratch ; since deleting add-ons, data and resetting the config files didn't work until now.

Surprisingly, the factory reset didn't bring back the issues after putting back the add-ons and data files from the previous FTP save, so I'm starting to assume that this whole succession of diverse ULX errors happened to come, in fact, from another folder that I'm still to this day unable to identify.

To find out the troublemaker, I could indeed provide you these files as well as my old save, if you would like to obtain some info about the current config I had until now.

Additionally, I will not claim victory yet, since I still have to add back some things like my sv.db and probably some other \data folders from some add-ons. I will give you the said files when coming back on my computer tomorrow.

Anyways, thanks again for the support.
Removing the xgui_managebans permission didn't fix the issue

Just to double check, do make sure you have completely removed the permission, by default it's on both the superadmin and also inherited from the admin group. If successful, the "bans" tab should not be shown at all in XGUI.


If you really want to rule out third party addons, the best test would be to set up a plain vanilla server on the sandbox gamemode on a standard map (like gm_flatgrass), then make sure there are no other addons or workshop mods installed besides ULX and ULib.


If that still isn't working, and if you're comfortable sharing, could you send me the following configuration files from your server? I could take a quick peek and see if anything stands out of the ordinary. Don't post them publicly, either DM me or send them to If any of these files contain an RCON password, please remove that before sending it to me.
 - garrysmod\data\ulib\*
 - garrysmod\data\ulx\*
 - garrysmod\cfg\banned_ip.cfg
 - garrysmod\cfg\banned_user.cfg
 - garrysmod\cfg\network.cfg
 - garrysmod\cfg\server.cfg
 - garrysmod\sv.db

(Alternately, you could try deleting some of these above files to ensure a clean server slate and see if that helps solve anything. Make a copy first!)
Good evening, first, thank for your answer.

I have indeed tried both the Workshop and Github versions, without any enhancement.
• When it comes to the bans, it would be odd since I never had the opportunity to use such feature (yet I suppose). Removing the xgui_managebans permission didn't fix the issue, but after some additional attempts I noticed that the error code's number changed (it is not the first time it happens) :

Code: [Select]
[ulib] lua/includes/extensions/net.lua:194: net.ReadType: Couldn't read type 244
    1. error - [C]:-1
        2. ReadType - lua/includes/extensions/net.lua:194
            3. ReadTable - lua/includes/extensions/net.lua:134
                4. func - addons/ulib/lua/ulib/client/cl_util.lua:9
                    5. unknown - lua/includes/extensions/net.lua:38

Going through these files, I struggled finding anything that could be explaining the cause of such issues. Removing back every addons adding external ULX commands didn't do the trick.

• If it comes from a third-party addon, I am having a really hard time trying to identify the culprit, it almost seems like multiple addons that are entirely unrelated to ULX are causing the trouble, when I'm removing them, the error disappears before appearing back again after a second restart, even if the said addon isn't there anymore. I have tried removing all my scripts one after another, listing some of them as potential troublemakers, but without any success.

If it helps, I will stay on the latest Github version, maybe it could help at some point in the future. I'll try some other fixes in the meantime.
Thanks again for your reply.

Just to confirm, you're installing our workshop versions of ULX and ULib? Or did you try our latest git versions as well?

Based on your report, my most likely suspicion is that you might have a corrupted or large amount of bans. Could you try removing the "xgui_managebans" permission for your user groups (and inherited groups) and see if it helps resolve the issue?
Community Servers / Polaris | SCP-RP
« Last post by Thermock on September 06, 2023, 02:44:32 PM »
?Polaris? SCP-RP Garry's Mod server

Polaris has opened up a new SCP-RP server. We're looking for players to join us! We are a small community looking to build ourselves up to provide a fun and engaging SCP-RP environment. We're looking for more staff members to help assist in running the community.

Below is some of the features our SCP-RP offers:

-Over twenty playable SCPs.
-Several non-player SCPs which enhance the roleplay environment.
-Several custom SCPs.
-A work-in-progress 'surface resident' faction, allowing people to 'escape' to the surface and live as a citizen.
-A work-in-progress 'self-breach' system.
-In-depth Chaos Insurgency and MTF roleplay.
-Easy-to-understand rules and SOPs
-Well-trained moderators
-Almost everything is free for all players

Give Polaris a chance! Join us today!

Server IP:
Hello there, I come seek help here today regarding an ULib issue that I have met approximately two months ago. After multiple attempts and tries to fix it, I appear to be now out of ideas, as for where this issue might come from in the first place.

What this problem does is that after logging in on my server as a superadmin, I appear to not be able to fully load the ULX menu that always gets stuck around 91%. The issue makes some modules such as the server adverts being broken, as they don't appear to work anymore.

Some of my staff members also reported the issue, so I know that it is not coming from me.
I have also tried setting myself as an user. Having a restricted access to ULX, the addon now loads correctly as a simple player, and is getting broken again when I put myself or anybody back at the superadmin usergroup.

Others fixes I have tried are also listed below :
- getting rid of anything related to ulib/ulx in the garrysmod/data folder in the FTP ;
- getting rid of every addons related to ULX ;
- removing everything from the workshop ;
- uninstalling / reinstalling individual addons one after another ;
- deleting the server-side addons included in my garrysmod/addons folder ;

Removing the entire collection from the server partially worked, but the issue appeared to come back after a restart.

• My ULib version is v2.71d (08/05/22)
• The ULX version is v3.81d (07/13/23)
I also want to lay on the fact that multiple versions of ULX and ULIB have been tested, without any success at fixing the issue.

I'm hosting a server using the Dark RP gamemode (referred as Military RP for the purpose of the said server).

Lua errors shown in console, if any:
Code: [Select]
[ulib] Trying to send an overflowed net message!
1. unknown - addons/ulib/lua/ulib/server/util.lua:33
2. pcall - [C]:-1
3. fn - addons/ulib/lua/ulib/shared/util.lua:466
4. unknown - addons/ulib/lua/ulib/shared/hook.lua:109
[ulib] Trying to send an overflowed net message!
1. unknown - addons/ulib/lua/ulib/server/util.lua:33
2. pcall - [C]:-1
3. fn - addons/ulib/lua/ulib/shared/util.lua:466
4. unknown - addons/ulib/lua/ulib/shared/hook.lua:109
ServerLog: [FAdmin] Ludwig Köhle Von Feuerwald (STEAM_0:1:147274851) Attempted to switch noclip
05/09/2023 17:15:10
[ulib] lua/includes/extensions/net.lua:194: net.ReadType: Couldn't read type 176
1. error - [C]:-1
2. ReadType - lua/includes/extensions/net.lua:194
3. ReadTable - lua/includes/extensions/net.lua:134
4. func - addons/ulib/lua/ulib/client/cl_util.lua:9
5. unknown - lua/includes/extensions/net.lua:38

Thanks per advance for any person willing to provide support.
Pages: [1] 2 3 ... 10